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1. Introduction

This is a demo version of GopherGolf Editor. It is fully functional except it will not allow you to save 
courses. For information on how to register your copy and play immediately see the GopherGolf 
Manual or print the order form from GopherGolf (choose Order Form from the Game menu).

The GopherGolf Editor allows you to create your own GopherGolf courses. You can alter courses that 
came with the package or you can create your own from scratch.

2. Starting

To start GopherGolf Editor double click on its icon. To alter an existing course choose Open from the File
menu and open one of the courses supplied. Choose Save as... from the File menu and give your new 
course a name. This will leave the original course unchanged. If you want to create a new course 
choose New from the File menu.

3. Work areas

The GopherGolf Editor has two work areas, The course area and the palette area. 

A. Course area

The course is created in the course area. It will appear exactly the same in GopherGolf as it does in 
GopherGolf Editor. The course area is located on the left side of the screen.

B. Palette area

The palette area is where you get all the pieces that you need to build your course. This section is not 
shown in the GopherGolf game application. The palette area has multiple pages. To move to a different
page click on the pointing hands at the top of the palette area. Each page contains different pieces 
that you can use on your course. The other two icons at the top of the palette area are the blank and 
the outline icons. The blank icon (left) will clear the course area of all objects for the hole you are 
working on. The outline icon (right) clears the course area and creates the biggest rectangle border 
allowed on your monitor size.

There are two types of things on the palette you can use to create your course, grid pieces and object 
pieces.

4. Grid pieces

The base of the course is made up of the red walls that you saw in the GopherGolf program. These are 
called grid pieces. The first pages of the palette consist of grid pieces. They align to a grid in the 
course area. The sizes of the grids vary according to the size of your monitor. A thirteen inch or larger 
monitor will have a ten by ten grid, a nine inch monitor will have a seven by six grid. To view the grid 
select Toggle grid from the View menu. This grid can be hidden again by selecting Toggle grid again. 
The grid can be visible or not visible but the grid is always active. 



To move grid pieces from the palette to the course area click on the piece you want to add to your 
course and drag it onto the course area. Once on the course area you can move it by clicking on it 
again and dragging it to a new location. If you hold down the option key while dragging a piece already
on the grid the piece is copied and put at the new location.

Sometimes placing the grid pieces on the grid is a little tricky (especially when placing diagonal 
pieces). Try toggling the grid view on to see exactly where the pieces will go when you place them.

Grid pieces become selected when you click on them. When selected you can move them one grid 
space at a time by using the arrow keys or number keys on the numeric keypad (8 up, 4 left, 6 right, 2 
down). If you hit the backspace (delete) key the selected grid piece will be deleted.

There are some special grid pieces that don't have walls on them. They are for landscaping only. 
Normally these would be placed outside the playing area. They can be placed anywhere on the hole 
but they will not effect the ball at all.

5. Object pieces

Object pieces are on the palette pages after the grid pages. Objects are tubes, holes, buildings, slopes,
water and bridges. These items don't align to grid. They can be placed anywhere on the course area. 

Object pieces become selected when you click on them. When selected you can move them one pixel 
at a time by using the arrow keys or number keys on the numeric keypad (8 up, 4 left, 6 right, 2 down).
If you hit the backspace (delete) key the selected object piece will be deleted.

Each object behaves differently and has some rules applied to its use. These will be covered next.

A. Tee and hole

These objects are obvious. They must be included in every hole.

B. Tubes

Tubes are simple objects. The ball enters one side and exits the other. Tubes that loop must be entered 
with sufficient speed or the ball will exit out the same side it entered. The only rule for tubes is to make
sure there is at least 1/4 inch between any openings and any other objects except slopes. This means 
you can't make a longer tube by connecting them end to end. Leave the 1/4 inch between them or you
will get unusual results.

C. Water

Water objects are special. They, along with slopes, are the only objects that can overlap each other or 
be overlapped by other objects. Water objects should not be placed within 1/4 inch of any ball exits. 
This includes tube, building and hole exits. The ball must be traveling at a sufficient rate of speed to 
get over the water.  If more than one water object are clumped together the ball must maintain this 
minimum speed at all times while it is over the objects.



D. Regular castle

The regular castle is pretty simple. The ball enters through one of its doors and has a 50/50 chance of 
exiting from either of the other doors. As with tubes, the doors of the castle should have a minimum 
clearance of 1/4 inch from all other objects except slopes.

E. Pyramid

A pyramid acts like a regular castle except when a ball enters one of its doors it will always exit from 
the door on the opposite side. Again the doors of the pyramid should have a minimum clearance of 1/4
inch from all other objects except slopes.

F. Tunnel

The tunnel (next to the water object) has two parts. When you place it on the course area the second 
part becomes visible. The second part is an exit. The ball enters the tunnel and exits through the exit. 
The exit must have the same minimum clearance as other object exits. You can only place one tunnel 
per hole. The tunnel object has other parameters. You can set the maximum exit angle, minimum exit 
speed and maximum exit speed. Once a tunnel is placed on the course area two menu items in the 
Object menu become available. The first, Tunnel settings, brings up a dialog to let you alter the 
attributes. You can also get to this dialog box by double clicking the tunnel object.  The second menu 
item is Tunnel direction which allows you to rotate the tunnel exit to the direction you want. The exit 
angle is random from zero to the value you set as its maximum. Zero being straight out the tunnel exit.
The maximum angle is measured from this center line in the positive and negative direction (see 
Figure 1).  If the minimum and maximum exit speeds are equal the ball will always exit the tunnel at 
that speed.  You have to be a little careful placing the exit. If you experiment you can make the ball go 
from the exit back into the tunnel again. Yes, you can break the laws of physics.

Figure 1

G. Bridge

The bridge is another simple object that acts as you would expect. The bridge is arched so the surface 
slopes up in the middle. The ball can not pass under the bridge. The slope of the bridge can not be 
changed.

H. Windmill

The windmill is a special object type called a mover. The vanes of the windmill move in real time as 
you play GopherGolf. The same clearance should be maintained in front of both openings of the 
windmill, 1/4 inch. When you place a windmill on the course area the Mover settings item in the Object 
menu becomes available. Selecting this menu item brings 



up a dialog box that allows you to set the speed of the windmill between one and ten. One is the 
slowest setting and ten is the fastest. Another way to make the dialog box come up is to double click 
on the windmill. You are allowed one mover per hole.

I. Moving castle

The moving castle is another mover object. The drawbridge of the castle opens and closes. The ball 
can only get through when the drawbridge is completely down and not moving. The same restriction as
the windmill apply to the castle and there is one more. You must leave a clearance space in front of the
drawbridge itself too. When you place a moving castle on the course area the Mover settings item in 
the Object menu becomes available. Selecting this menu item brings up a dialog box that allows you to
set the speed of the moving castle between one and ten. One is the slowest setting and ten is the 
fastest. Another way to make the dialog box come up is to double click on the moving castle. You are 
allowed one mover per hole. You can put water or slopes under the drawbridge.

J. Signs

Signs allow you to enter text into them. You can put anything you want in them, hole names, par, etc. 
When you place a sign on the course area the Sign text menu item in the Object menu becomes 
available. Selecting this item brings up a dialog box that lets you enter the text. You can also double-
click on the sign to get the dialog box. You can have only one sign per hole. The sign does not effect 
the way the ball moves at all.

K. Slopes

The last group of objects are the slopes. The lighter part of the slope is "higher" than the darker part 
(see Figure 1 in the GopherGolf manual). The slopes have an attribute called the slope factor. This is a 
number between one and ten. One is the "flattest" and ten is the "steepest." Since there can be more 
than one slope on each hole you must select the slope by clicking on it to change its slope factor. 
When a slope is selected the Slope settings menu item in the Object menu is available. This menu item
brings up a dialog box allowing you to change the slope factor for the selected slope. You can also get 
this dialog box by double clicking on the slope object you want to alter. Usually it is a good idea to 
leave a little space between down slopes and walls (see Figure 2).

                                         

Figure 2
6. Testing

The only real way to test your course is to build them and play them. If for some reason the ball gets 
"stuck" somewhere on your course while in GopherGolf (the putter will not show up even when it looks 
as if the ball has stopped moving) hold down the 'q' key. This will exit GopherGolf. You can then edit 
your course to move the objects that were causing trouble. The best part of GopherGolf Editor is that 
you can experiment. Try any ideas you have. If they don't work the first time you can change them and
try again.

7. Hierarchy



The objects on the course can be moved on top of all other objects by selecting the object and 
choosing Move to front from the Object menu. To move the object to the back choose Move to back 
from the object menu. The grid pieces are always in the background. The tee and hole are always the 
front most objects.

8. Course size

There are three different sizes of courses supported by GopherGolf. 1) 9" monitor and 12" color 
monitor (7 x 7 grid) 2) powerbook screens (10 x 8 grid) 3) 13" monitor or larger (10 x 10 grid). Using 
GopherGolf, you should only open courses that have the same or smaller grid size as your monitor. 
Courses created on a 9" monitor will run on all other monitors but a course created on a powerbook 
may have objects placed out of view on a 9" monitor. You can simulate a smaller screen by holding 
down certain keys when you start up GopherGolf Editor. If you have a powerbook or 13" monitor, hold 
down the '1' key to simulate a 9" screen. If you have a 13" monitor, hold down the '2' key to simulate a
powerbook screen. When the courses are saved they will be saved at the size you simulated.

9. Menus

A. File menu

New : Creates a new course.
Open : Opens an existing course.
Close :  Closes the current course.
Save : Saves the current course to disk.
Save as... : Saves the current course with a new name.
Quit : Quits GopherGolf Editor.

B. Hole menu

If you want to move to a different hole choose the hole you want from the Hole menu. This will put a 
check mark next to that hole number and take you to that hole. Also in the Hole menu you can go to 
the first hole by choosing First, the previous hole with Previous, the next hole with Next, and the last 
hole with Last.

C. Object

Move to front : Moves the currently selected object on top of all other objects.
Move to back : Moves the currently selected object beneath all other objects.
Tunnel settings : Lets you change the settings if there is a tunnel on the current hole.
Tunnel direction : Sets the direction of the tunnel exit if there is one on the current hole.
Mover settings : Sets the speed of the mover object if there is one on the current hole.
Slope Settings : Sets the slope factor for the selected slope object.
Sign text : Lets you enter text into a sign if there is one on the current hole.

D. View

Toggle grid : Shows and hides the grid.

E. Course

Max Strokes: Lets you enter a maximum number of strokes per hole in competition mode.


